This project is read-only.

Missing or invalid form parameter 'WorkflowDefinition'

Jun 4, 2009 at 9:20 AM

Hi,

First of all thanks for this great Framework. I think MS could also learn a lot from this solution.

I've tried to create my first Workflow with WSS3 Workflow Tools. I've followed the tutorial but during the association of my workflow i've received the following error message:

Missing or invalid form parameter 'WorkflowDefinition'   at TPG.SharePoint.Workflow.QueryStringParser.GetParameter[T](String name, Boolean allowNull, TypeConverter converter)
   at TPG.SharePoint.Workflow.QueryStringParser.GetParameter[T](String name, Boolean allowNull)
   at TPG.SharePoint.Workflow.QueryStringParser.GetParameter[T](String name)
   at TPG.SharePoint.Workflow.AssociationPage.get_WorkflowTemplateID()
   at TPG.SharePoint.Workflow.AssociationPage.GetWorkflowTemplate()
   at TPG.SharePoint.Workflow.LayoutWorkflowPage.get_WorkflowTemplateInternal()
   at TPG.SharePoint.Workflow.LayoutWorkflowPage.TPG.SharePoint.Workflow.IWorkflowPage.get_WorkflowTemplate()
   at TPG.SharePoint.Workflow.WorkflowControlPlaceHolder.OnInit(EventArgs e)
   at System.Web.UI.Control.InitRecursive(Control namingContainer)
   at System.Web.UI.Control.InitRecursive(Control namingContainer)
   at System.Web.UI.Control.InitRecursive(Control namingContainer)
   at System.Web.UI.Control.InitRecursive(Control namingContainer)
   at System.Web.UI.Control.InitRecursive(Control namingContainer)
   at System.Web.UI.Control.InitRecursive(Control namingContainer)
   at System.Web.UI.Control.InitRecursive(Control namingContainer)
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Instead the "Sequential Workflow Library" VS Project Template I've used the "SharePoint 2007 Sequential Workflow" Teplame without automatic Wf association. Can it be the problem?

I use: VS 2008, WinServer 2003 R2

Thanks in Advance

Regards

Valden

Coordinator
Jun 4, 2009 at 9:31 AM
Could you post your workflow.xml file? I think there might be an issue there.

Thanks, Wouter

________________________________

Van: Valden [mailto:notifications@codeplex.com]
Verzonden: do 4-6-2009 10:20
Aan: Wouter van Vugt
Onderwerp: Missing or invalid form parameter 'WorkflowDefinition' [wss3workflow:58420]



From: Valden

Hi,

First of all thanks for this great Framework. I think MS could also learn a lot from this solution.

I've tried to create my first Workflow with WSS3 Workflow Tools. I've followed the tutorial but during the association of my workflow i've received the following error message:

Missing or invalid form parameter 'WorkflowDefinition' at TPG.SharePoint.Workflow.QueryStringParser.GetParameter[T](String name, Boolean allowNull, TypeConverter converter)
at TPG.SharePoint.Workflow.QueryStringParser.GetParameter[T](String name, Boolean allowNull)
at TPG.SharePoint.Workflow.QueryStringParser.GetParameter[T](String name)
at TPG.SharePoint.Workflow.AssociationPage.get_WorkflowTemplateID()
at TPG.SharePoint.Workflow.AssociationPage.GetWorkflowTemplate()
at TPG.SharePoint.Workflow.LayoutWorkflowPage.get_WorkflowTemplateInternal()
at TPG.SharePoint.Workflow.LayoutWorkflowPage.TPG.SharePoint.Workflow.IWorkflowPage.get_WorkflowTemplate()
at TPG.SharePoint.Workflow.WorkflowControlPlaceHolder.OnInit(EventArgs e)
at System.Web.UI.Control.InitRecursive(Control namingContainer)
at System.Web.UI.Control.InitRecursive(Control namingContainer)
at System.Web.UI.Control.InitRecursive(Control namingContainer)
at System.Web.UI.Control.InitRecursive(Control namingContainer)
at System.Web.UI.Control.InitRecursive(Control namingContainer)
at System.Web.UI.Control.InitRecursive(Control namingContainer)
at System.Web.UI.Control.InitRecursive(Control namingContainer)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Instead the "Sequential Workflow Library" VS Project Template I've used the "SharePoint 2007 Sequential Workflow" Teplame without automatic Wf association. Can it be the problem?

I use: VS 2008, WinServer 2003 R2

Thanks in Advance

Regards

Valden

Read the full discussion online <http://wss3workflow.codeplex.com/Thread/View.aspx?ThreadId=58420&ANCHOR#Post197617> .

To add a post to this discussion, reply to this email ([email removed] <mailto:[email removed]?subject=[wss3workflow:58420]> )

To start a new discussion for this project, email [email removed]

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings <http://www.codeplex.com/site/discussions/project/unsubscribe/wss3workflow> on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com
Jun 4, 2009 at 9:52 AM

Here is my Workflow.xml

<?xml version="1.0" encoding="utf-8" ?>
<Elements xmlns="http://schemas.microsoft.com/sharepoint/">
  <Workflow Id="13DCA4CF-D0A0-4622-9AD5-55C0BA69203A"
            Name="SimpleApprovalWorkflow"
            Description="Simple approval"
            Title="Simple Approval Workflow"
            CodeBesideAssembly="SimpleApprovalWorkflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=c519d759670e0413"
            CodeBesideClass="SimpleApprovalWorkflow.Workflow1"
            AssociationUrl="_layouts/WSS3Workflow/AssociationFormHost.aspx"
            InstantiationUrl="_layouts/WSS3Workflow/InstantiationFormHost.aspx">
    <MetaData>
      <Association_FormUrl>/_controltemplates/SimpleApprovalWorkflow/WorkflowConfiguration.ascx</Association_FormUrl>
      <Instantiation_FormUrl>/_controltemplates/SimpleApprovalWorkflow/WorkflowConfiguration.ascx</Instantiation_FormUrl>
      <StatusPageUrl>_layouts/WrkStat.aspx</StatusPageUrl>
    </MetaData>
  </Workflow>
</Elements>

Coordinator
Jun 4, 2009 at 10:03 AM
No issues there.

The funky thing is that the parameters are passed by SharePoint, and I do not expect SharePoint to leave out any parameters in just this case. We haven't seen this issue before. I'll try and dig some more.

wouter

________________________________

Van: Valden [mailto:notifications@codeplex.com]
Verzonden: do 4-6-2009 10:52
Aan: Wouter van Vugt
Onderwerp: Re: Missing or invalid form parameter 'WorkflowDefinition' [wss3workflow:58420]



From: Valden

Here is my Workflow.xml

<?xml version="1.0" encoding="utf-8" ?>
<Elements xmlns="http://schemas.microsoft.com/sharepoint/">
<Workflow Id="13DCA4CF-D0A0-4622-9AD5-55C0BA69203A"
Name="SimpleApprovalWorkflow"
Description="Simple approval"
Title="Simple Approval Workflow"
CodeBesideAssembly="SimpleApprovalWorkflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=c519d759670e0413"
CodeBesideClass="SimpleApprovalWorkflow.Workflow1"
AssociationUrl="_layouts/WSS3Workflow/AssociationFormHost.aspx"
InstantiationUrl="_layouts/WSS3Workflow/InstantiationFormHost.aspx">
<MetaData>
<Association_FormUrl>/_controltemplates/SimpleApprovalWorkflow/WorkflowConfiguration.ascx</Association_FormUrl>
<Instantiation_FormUrl>/_controltemplates/SimpleApprovalWorkflow/WorkflowConfiguration.ascx</Instantiation_FormUrl>
<StatusPageUrl>_layouts/WrkStat.aspx</StatusPageUrl>
</MetaData>
</Workflow>
</Elements>


Read the full discussion online <http://wss3workflow.codeplex.com/Thread/View.aspx?ThreadId=58420&ANCHOR#Post197629> .

To add a post to this discussion, reply to this email ([email removed] <mailto:[email removed]?subject=[wss3workflow:58420]> )

To start a new discussion for this project, email [email removed]

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings <http://www.codeplex.com/site/discussions/project/unsubscribe/wss3workflow> on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com
Jun 4, 2009 at 10:12 AM

Hi,

I've started everything over with the "Sequential Workflow Library" template, and it works.

I used iisreset after every redeploy. I try to fix the other soution with the "SharePoint 2007 Sequential Workflow".

Thanks for the immediate answer.

Ragards

 

Valden

Coordinator
Jun 4, 2009 at 10:23 AM
Good to hear. If you have time, please provide us with a review on the release page.

Thanks

Wouter

________________________________

Van: Valden [mailto:notifications@codeplex.com]
Verzonden: do 4-6-2009 11:13
Aan: Wouter van Vugt
Onderwerp: Re: Missing or invalid form parameter 'WorkflowDefinition' [wss3workflow:58420]



From: Valden

Hi,

I've started everything over with the "Sequential Workflow Library" template, and it works.

I used iisreset after every redeploy. I try to fix the other soution with the "SharePoint 2007 Sequential Workflow".

Thanks for the immediate answer.

Ragards



Valden

Read the full discussion online <http://wss3workflow.codeplex.com/Thread/View.aspx?ThreadId=58420&ANCHOR#Post197636> .

To add a post to this discussion, reply to this email ([email removed] <mailto:[email removed]?subject=[wss3workflow:58420]> )

To start a new discussion for this project, email [email removed]

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings <http://www.codeplex.com/site/discussions/project/unsubscribe/wss3workflow> on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com