ButtonSection on TaskControl

Jun 10, 2009 at 10:07 AM

Hello,

Couple days ago we had contact about the double/decimal issue regarding the meta data on task controls/pages. Thanks for fixing this :)!

During the rest of the implementation i encountered some strange behaviour when i tried to hide a button from the button section of the input control in case of a already finished task. During the load, i tried to set the buttons Visible property to false, but the button was null. When i searched for it in the many levels of controls, i did found it. However, this not really the way i want to search for a reference to my button ;).

At this moment i implemented this in the Init event handler of the button. Is it correct that it this button is not instantiated during the onload. I also tried the same during the OnPreRender, but it gave me the same problem.

Thanks for this product by the way, makes my workflow becoming pretty cool :)

Coordinator
Jun 10, 2009 at 10:15 AM

I will check this later today or Friday.

Wouter

From: Dehussler [mailto:notifications@codeplex.com]
Sent: woensdag 10 juni 2009 12:08
To: Wouter van Vugt
Subject: ButtonSection on TaskControl [wss3workflow:59038]

From: Dehussler

Hello,

Couple days ago we had contact about the double/decimal issue regarding the meta data on task controls/pages. Thanks for fixing this :)!

During the rest of the implementation i encountered some strange behaviour when i tried to hide a button from the button section of the input control in case of a already finished task. During the load, i tried to set the buttons Visible property to false, but the button was null. When i searched for it in the many levels of controls, i did found it. However, this not really the way i want to search for a reference to my button ;).

At this moment i implemented this in the Init event handler of the button. Is it correct that it this button is not instantiated during the onload. I also tried the same during the OnPreRender, but it gave me the same problem.

Thanks for this product by the way, makes my workflow becoming pretty cool :)

Read the full discussion online.

To add a post to this discussion, reply to this email (wss3workflow@discussions.codeplex.com)

To start a new discussion for this project, email wss3workflow@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Aug 4, 2009 at 3:29 PM

Has there been any resolution to this - I'm working on the same issue right now.

Coordinator
Aug 4, 2009 at 4:23 PM

Chris and I have been busy working. I think we both have time to resolve this over this week / weekend.

Best regards,

Wouter van Vugt
MVP Visual Studio Tools for Office

Envelope

wouter@code-counsel.net

Telephone

+31 6  438 317 12

icon_twitter

@woutervugt

RSS

http://blogs.code-counsel.net/wouter

Logo 7 cm

Code Counsel

Critical Path Training

CPT

Sharing Knowledge with Passion
www.code-counsel.net

Your fastest way up the SharePoint learning curve!
www.criticalpathtraining.com

From: semmons23 [mailto:notifications@codeplex.com]
Sent: dinsdag 4 augustus 2009 17:30
To: Wouter van Vugt
Subject: Re: ButtonSection on TaskControl [wss3workflow:59038]

From: semmons23

Has there been any resolution to this - I'm working on the same issue right now.

Read the full discussion online.

To add a post to this discussion, reply to this email (wss3workflow@discussions.codeplex.com)

To start a new discussion for this project, email wss3workflow@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Aug 10, 2009 at 8:00 PM

Were you able to determine anything?

Coordinator
Aug 10, 2009 at 8:13 PM

Unfortunately we haven't had time to look at the problem just yet.  I'm trying as hard as I can to get some time set aside in the next few days to look into this.

Sep 4, 2009 at 3:27 AM

any luck?

Jan 5, 2011 at 7:56 AM

I think this issue is still not soved.

The workarround I used is creating another ButtonSection with a Cancel button only. I made this one invisible by default.

When certain condtions have met I make it visible and I make the ButtonSection with the approve button invisible.