how to have the form appear when user click on task (not on edit)

Nov 20, 2009 at 5:18 PM

Hi,

it seems that with hosted controls when the user click on the task they get they are shown the usual display task form, and when clicking edit they get to the form we specify.

How can I change this behaviour so that the user gets to the edit form immediately?

 

Thanks,

Robert

Nov 26, 2009 at 5:56 PM

Well, I guess it was easier than it looked. I've created a custom content type inheriting from your task contenty type and setting both Edit and Display tags to your formhost. 

 

Feb 12, 2010 at 5:42 AM

so, how you solve it ? i've try to add this section but failed. Still display standard View Form.

 

<Display>_layouts/WSS3Workflow/TaskFormHost.aspx</Display>

Thanks, Ishak

 

Coordinator
Feb 12, 2010 at 3:33 PM

Where did you add that section?  If you created a new content type derived from the one in the toolkit will you post the updated content type and your workflow.xml file?

Chris

Jul 2, 2010 at 3:38 PM

It is not working for me neitiher, i am changed the wss3workflow contenttype.

The steps i did:

1) Change the workflow.xml in the feature folder direclty in the 12 folder with this:

<XmlDocuments>
   <XmlDocument NamespaceURI="http://schemas.microsoft.com/sharepoint/v3/contenttype/forms/url">
    <FormUrls xmlns="http://schemas.microsoft.com/sharepoint/v3/contenttype/forms/url">
     <Display>_layouts/WSS3Workflow/TaskFormHost.aspx</Display>
     <Edit>_layouts/WSS3Workflow/TaskFormHost.aspx</Edit>
    </FormUrls>
   </XmlDocument>

2) I deactivate the wss3workflow feature, uninstall the feature, then reinstall the feature and activate the feature again, and it is showing the deafalut form for the view....

 

What i missing???

Thanks

 

 

Sep 17, 2010 at 8:18 PM
Edited Sep 17, 2010 at 8:33 PM

To remove any references to the content type, you have to be tricky and get to the hidden site collection level content type!

 

1) you have to first enable "allow manage content types" on the task list in question (in the list settings)

2) Click on TPG.SharePoint.Workflow Task Content Type to edit it

3) next to the word Parent: on the List Content Type Screen, right click on the words TPG.SharePoint.Workflow Task Content Type 

4) Copy the link url, paste it into notepad, you'll need it in a minute

5) Go back to the Task List "List Settings" page and this time, remove it from the list.

6) Paste the url you copied to notepad into your browser.

7) Remove the content type from the site collection altogether by clicking 'Delete this content type'

8) Deactivate the feature

9) Edit the xml file adding the Display element

10) Reactivate the feature

11) Profit.

 

I've done this several times. When you have a custom task, in my opinion, there is no reason to ever just display it. You always want to use the 'new lens' you created for it. i know the authors of this application removed this feature on purpose, but I disagree with that decision. So, I constantly work around it like this (which I have to do on each new development server I set up)

As long as you know what happens in the black box, you can change it!

 

EDIT: Added the part about how to get to the hidden content type to remove it (Forgot the first time)